• Security Update

On December 2, 2017, McNaughton-McKay will update our website to meet the latest industry security standards. This update will decommission support for older versions of most commonly used internet browsers. After the upgrade, the following browsers and versions will be necessary (not a complete list):

  • Google Chrome, version 38 and higher
  • Mozilla Firefox, version 27 and higher; and ESR version 31.0 and higher
  • Internet Explorer, version 11 and higher
  • Edge, version 12 and higher
  • Safari, version 7 and higher
  • Opera, version 12.18 and higher

If you are not sure if your browser is compatible, you can test it here.
Test Your Browser

WHAT STEPS SHOULD YOU TAKE IF YOUR BROWSER FAILED THE TEST?
Please speak to your IT department about upgrading you and your organization to a supported browser version as this will impact all machines in your organization that connect to not only McNaughton-McKay but other eCommerce related sites in the near future.

HAVE QUESTIONS?
Contact us at mcmc@mc-mc.com or 844-687-6262, and ask to speak to someone on the eCommerce team.

Thank you in advance for helping us take this proactive step in continuing to protect your interests and your data security.

Copyright © 2017  McNaughton-McKay  All Rights Reserved.